
Adding A New Assignment

Each class can have many assignments.

Step-by-step instructions for adding a new assignment:
1. Select Add Assignment from the Assignments menu.
2. Enter a short description of the assignment, the maximum number of points, and the date.
3. Select OK.
4. The new assignment is displayed on the grade form. Scores can be entered for the assignment.

Additional Help Topics:
Deleting assignments
Average calculations



Adding A New Class

Grades are grouped in classes. Many classes can be stored together in one gradebook file.

Step-by-step instructions for adding a new class:
1. Select Add Class from the Classes menu
2. Enter the class name (i.e. Reading Comprehension) and the term (i.e. First Quarter    96-97). If using 
weighted grades, check the Use Weights box.
3. Select OK.
4. The Class Roster form appears. Select the class roster for the class from the list of students. Add names to 
the list using the boxes at the bottom of the screen or transfer all of the students from another gradebook file. Names 
can also be added or removed later.
5. Select OK.
6. The grade form for the class is displayed and is ready for its first assignment.

Additional Help Topics:
Adding a new assignment
Weights
Changing the class roster
Deleting a class
Selecting a class



Assignment Information

After a assignment is added to a class, its description, maximum points, weight, and date can be changed by typing 
new information in the Assignment Information Frame. The Assignment Information Frame appears at the top of the 
Grade Form. If it is not visible, select Show Assignment Information from the Format menu. To hide the Assignment 
Information Frame, select Hide Assignment Information from the Format Menu.

Additional Help Topics:
Adding a new assignment
Class information



Average Calculations

A2Z Gradebook automatically calculates averages while you work. The averages shown in the second column of the 
grade grid are always current. 

When Use Weights is not selected the averages are calculated according to this formula:
(Sum of the scores)/(Sum of the maximum points for the assignments) = Average

When Use Weights is selected the averages are calculated according to this formula:
(Sum of ((Score*Weight) / Maximum points))/(Sum of the weights) = Average

If a student has a blank score for an assignment, then that assignment is not used in the average calculation.

Additional Help Topics:
Entering Scores
Weights



Auto Assign Grades

Grades can be automatically assigned for the current class according to a scale. To do this, select Auto Assign 
Grades from the Grades and Scores menu. To assign the grades according to the displayed scale, select OK. To 
enter a different scale, select Change Scale.

In the Change Scale window, start by entering the highest grade and the select Add To List. Continue entering grades
until the entire scale has been entered. Then select OK. The new scale will become the default scale.

Automatically assigned grades can be overwritten by selecting the grade on the grade grid and entering a new grade. 
Grades are not updated according to scale on a continuous basis, but only when Auto Assign Grades is selected from
the Grades and Scores menu.



Auto Drop Scores

The lowest score (or scores) for all of the students in a class can be dropped from average calculations by selecting 
Auto Drop Scores from the Grades and Scores menu. Select the number of scores which you would like to drop for 
each student and select OK. Any scores which were previously marked dropped for the class will be cleared.

If weighted scores are being used, the lowest scores can be calculated according to straight percentages or weighted
percentages.    If weighted percentages are selected, the percentages are calculated according to

(Score * Weight) / (MaximumPoints * Sum of the Weights)

Scores which have been dropped have a yellow background on the grade grid and are marked dropped on reports. 
Bar characters | may also appear when the cell is selected. These are markers for dropped grades. It is alright to type
over these markers.



Changing the Class Roster

The class roster is the list of students in a class. Each gradebook file contains information on many students. Some 
or all of these students may be selected to be entered on the roster for a class.

Step-by-step instructions for changing the class roster:
1. Select Change Class Roster from the Classes menu.
2. In the list of students, select the name of each student for the class.
3. To add a name to the list, enter it using the box at the bottom of the form.
4. To transfer all of the students from another gradebook file to the current gradebook file, select the Browse 
command to find the gradebook file from which you want to transfer the student information. Once the file is located, 
select the Transfer command. The student names appear in the list and are available for selection.
5. After the students for the class are selected, select OK.
6. If a student who was previously on the class roster was deselected, you will be asked to confirm that you 
want to remove the student from the class. If the student is removed, any scores or grades which were entered for 
that student in that class will be deleted as well.

Additional Help Topics:
Changing student information
Adding a class



Changing the Password

The password for a gradebook can be changed after a gradebook is opened.

Step by step instructions for changing the password:

1. From the File menu, select Change Password.
2. Enter the new password in both boxes. If you dont want the gradebook to have a password, leave the boxes
blank.
3. Select OK.

Additional Help Topics:
Security issues



Changing Student Information

A students first name, last name , student ID, notes, or memo can be changed by selecting Student Information from 
the Students menu. Student averages can also be viewed graphically on this form.    An alternate way to view this 
information is to click on the grade grid in the cell with the students name and then click the small button which 
appears next to the students name.    

Additional Help Topics:
Changing the Class Roster



Class Information

After a class is added to the gradebook, its name, term, and notes can be changed by typing new information in the 
Class Information Frame. The Use Weights selection is also in the Class Information Frame. The Class Information 
Frame appears at the top of the Grade Form. If it is not visible, select Show Class Information from the Format menu.
To hide the Class Information Frame, select Hide Class Information from the Format Menu.

Additional Help Topics:
Adding a new class
Assignment information
Calculating Averages



Closing a Gradebook

The current gradebook file must be closed before opening another. To close the gradebook file, select Close from the 
File menu. If this option is not available, then there is not a gradebook file open.

Additional Help Topics:
Opening a Gradebook



Custom Reports

The standard reports included with A2Z Gradebook can be customized by A2ZWare for a small fee. Titles can be 
added or removed, data fields can be added or rearranged, colors and bitmaps can be added, HTML formats can be 
generated, etc. 

To order custom report files, send the desired report format to Technical Support. Due to limitations in the print engine
some report formats are not possible. You will receive a prompt response from Technical Support concerning the cost
and availability of the report. 

Additional Help Topics:
Technical Support



Deleting Assignments

Assignments can be deleted from the gradebook. Use this option carefully. After an assignment is deleted, the scores
for that assignment cannot be recovered.

Step-by-step instructions for deleting an assignment:
1. Select the assignment by clicking in the column for that assignment on the grade form.
2. Look at the assignment information to verify that the correct assignment is selected.
3. Select Delete Assignment from the Assignments menu
4. Select OK to delete the assignment.
5. You will be asked to confirm that you want to delete the assignment.

Additional Help Topics:
Adding Assignments
Assignment Information Frame



Deleting Classes

Classes can be deleted from the gradebook. Use this option carefully. After a class is deleted, the scores for that 
class cannot be recovered.

Step-by-step instructions for deleting a class:
1. Select the class using Select Class in the classes menu.
2. Look at the class information to verify that the correct class is selected.
3. Select Delete Class from the Classes menu
4. Select OK to delete the class.
5. You will be asked to confirm that you want to delete the class.

Additional Help Topics:
Adding Classes
Class Information Frame
Selecting A Class



Deleting Students

Students can be deleted from the gradebook. Use this option carefully. After a student is deleted, the scores for that 
student cannot be recovered.

Step-by-step instructions for deleting a student:
1. Select the student by clicking on the appropriate row in the grade form grid.
2. Select Delete Student from the Students menu
3. Select OK to delete the student.
4. You will be asked to confirm that you want to delete the Student.

Additional Help Topics:
Changing the Class Roster



Dropping Scores

Individual scores can be dropped from average calculations by selecting the score on the grade grid and then 
selecting Mark Score Dropped/Not Dropped from the Grades and Scores menu. If the score was previously not 
dropped, it will be marked not dropped. If the score was previously dropped, it will be marked not dropped.    Dropped 
scores will have a yellow background on the grade grid and will be marked dropped on reports. Bar characters | may 
also appear on the grid when the cell is selected. These are markers for dropped grades. It is alright to type over 
these markers.

Additional Help Topics:
Auto Drop Scores



Entering Scores and Grades

Scores and grades are entered by selecting the appropriate cell on the grade form grid and entering the data. 

Anything can be entered in the grade column (numbers, letters, etc.). Numbers or text can be entered as assignment 
scores. Non-numeric scores will be omitted from average calculations.    It is acceptable to enter a score which 
exceeds the maximum points for an assignment. 

Scores are saved to file as soon as they are entered. Averages are also recalculated immediately.

Additional Help Topics:
Calculating Averages



Getting Started

Welcome to A2Z Gradebook! Here are a few ideas about getting started.

The best way to learn about A2Z Gradebook is to use the sample gradebook which is included with this software. To 
open it select Open from the File menu. In the directory which holds your A2Z Gradebook files, look for 
SAMPLE.GRD. Select it and then select OK. It will prompt for a password. Leave the box empty and click OK. The 
gradebook will open and you are ready to go.

After the gradebook is opened, the grade form is displayed. Select Select Class from the Classes menu. Several 
classes will be listed. Select one from the list and select OK. Now you will see a grade grid displayed for that class. 
Try changing some grades in the sample gradebook. Also experiment with adding classes or assignments by using 
the menu commands.

To view a graphical representation of a students progress, select View Information from the Students menu. A new 
form is displayed with the students information and a graph of the grades. Try some of the other menu commands on 
this form. Select the Exit menu to return to the grade form.

To view or print reports, select one of the report types from the Reports menu. A report window opens. Try selecting 
different types of reports.

After you are comfortable with the sample gradebook, close it and create your own gradebook. 

Help is always available from the menus. Many forms also include help buttons and in many cases, selecting F1 will 
also open the help file. Feel free to contact Technical Support if you need any assistance with A2Z Gradebook. We 
hope you find it useful.

Dont forget to read the License Agreement!



License Agreement

A2Z Gradebook Copyright © 1996 -1998 by J. Szatkowski
All rights reserved.
License Agreement
You should carefully read the following terms and conditions before using this software.    Unless you have a different 
license agreement authorized by A2ZWare. your use of this software indicates your acceptance of this license 
agreement and warranty. Licenses are not transferable.

License Types

Unregistered Verision
You may use A2Z Gradebook free of charge for 30 days. After that you must register by purchasing a license.

Registered Versions

single-user license allows ONE INDIVIDUAL to use the A2Z Gradebook software at home or at school. Each person 
who will be using the software must purchase a single-user license regardless of how many computers the software 
is installed on.

A school license allows all current employees of the school to use the A2Z Gradebook software at home or at school. 
Once an individual is no longer employed by the school, that individual is no longer covered by the school license and
should purchase a new license. Single departments at UNIVERSITIES and COLLEGES should purchase a school 
license. COMPANIES using the software on multiple computers at a single site should also purchase a school 
license.

A district license allows all current employees of the school district to use the A2Z Gradebook software at home or at 
school. Once an individual is no longer employed by the school district, that individual is no longer covered by the 
district license and should purchase a new license. UNIVERSITIES and COLLEGES should purchase a district 
license to cover the entire institution. COMPANIES using the software at multiple sites should also purchase a district 
license.

Disclaimer of Warranty
THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD "AS IS" AND WITHOUT WARRANTIES AS TO 
PERFORMANCE OF MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED.
Because of the different kinds of hardware and software with which A2Z Gradebook may be used, NO WARRANTY 
OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED.

A2Z Gradebook has been tested extensively. However it is not possible to test every possible situation. The user 
assumes the entire risk of using A2Z Gradebook.    ANY LIABILITY OF THE SELLER WILL BE LIMITED 
EXCLUSIVELY TO PRODUCT REPLACEMENT OR REFUND OF PURCHASE PRICE.



Marking Scores Late

Scores can be marked late by selecting the score on the grade grid and then selecting Mark Score Late/Not Late 
from the Grades and Scores menu.    If the score was previously not marked late, it will be marked late. If the score 
was previously marked late, it will be marked late.

Score which have been marked late are shown in red on the grade grid and are marked late on reports. Bar 
characters | may also appear on the grade grid when the cell is selected. These are markers for late grades. It is 
alright to type over these markers.



New File Menu
This menu item creates a new gradebook.

Step by step instructions for creating a new gradebook:

1. From the File Menu, select New. (If this option is not available, you may already have a gradebook open. Close 
that gradebook first by selecting Close from the File Menu.)

2. Select the drive for the new gradebook. (If security is a concern, consider keeping the gradebook on a 
diskette.)
3. Select the folder (directory) for the new gradebook.
4. Type in the name of the new gradebook. The extension must be .GRD.
5. Select OK.
6. You are prompted to enter a password. Enter the password in both boxes and select OK. If you dont want a 
password, just leave the boxes blank.
7. A blank grade form appears. 

Additional help topics:
Working with the grade form
Changing the password
Closing the gradebook



Open File Menu
This menu item opens an existing gradebook.

Step by step instructions for opening a gradebook:

1. From the File Menu, select Open. (If this option is not available, you may already have a gradebook open. Close 
that gradebook first by selecting Close from the File Menu.)

2. Select the drive and    the folder (directory) for the gradebook.
3. The gradebook files are listed. Select one. (If no files are listed, then there are no gradebook files in the 
folder you have selected. Select a different folder.)
4. Select OK.
5. You are prompted to enter the password. Type the password for the gradebook in the box and select OK. If 
the gradebook doesnt have a password, just leave the box blank.
6. The grade form appears

Additional Help Topics:
Working with the grade form
Changing the password
Closing the gradebook



Print Preview

Print preview is an approximation of how the printed document will appear. Occasionally, there will be formatting 
errors which appear in the print preview window, but not in the document itself. 

Use the Next Page and Previous Page commands to view the document in print preview. The Zoom In and Zoom out 
commands allow you to view the whole page at once or to view a detail on the page.

If you are satisfied with the document, use the Print command to send the document to your printer. Select the pages 
to print and the number of copies. You can change your printer setup by exiting print preview and selecting Printer 
Setup from the previous window. It is not recommended that you change your printer setup while in print preview 
because the document has been formatted for the printer which was selected when the print preview window was 
opened.



Registration

To register A2Z Gradebook, select How to Register from the Help Menu. Read the license descriptions carefully to 
determine the type and quantity of licenses you need. Select OK to start the register program. It will guide you 
through the payment process.

A2ZWare uses a payment processing service called Kagi. Payments will be sent to Kagi and Kagi will notify A2ZWare
when the payments have been processed. Questions about the status of your payment should be directed to 
Kagi at admin@kagi.com, not to A2ZWare.

After your payment is received, you will receive a registration code from A2ZWare. Enter this code by selecting Enter 
Registration Code from the Help menu. After your registration code is entered you will not be interrupted by 
shareware reminders anymore. 



Reports

Many standard reports are available in A2Z Gradebook. They are grouped into three categories: student reports, 
assignment reports, and class reports. Custom reports are also available from A2ZWare. 

Step-by-step instructions for viewing and printing reports:
1. Select the appropriate report type from the Reports menu.
2. Select the report format from the choices given and then select OK.
3. Select the students, classes, and/or assignments to include in the report.
4. Select Printer Setup to change the printer, paper orientation, and other printer options.
5. Select View Report to open the report preview window.
6. Use the Previous Page and Next Page commands to view the pages in the report.
7. Select the Print All Pages command to print the entire report or the Print Current Page command to print the 
page currently displayed in the print preview window.
8. Select the Close command to close the window.

Additional Help Topics:
Custom Reports
Statistics



Security Issues

Keeping the gradebook safe from unauthorized access is an important concern. While passwords will hamper any 
attempts at unauthorized access, they cannot guarantee security. The best way to keep the files completely secure is 
to keep the files on diskette and store the diskette in a safe location.

Additional Help Topics:
Changing the password



Selecting A Class

Each gradebook file can store the grades for many classes. Selecting a class is simple.

Step-by-step instructions for selecting a class:
1. Select Select Class from the Classes menu.
2. In the list, select the class.
3. Select OK.

Additional Help Topics:
Adding a class
Class information



Statistics

Some reports include statistics. These include the variance and standard deviation for the selected group.    These 
are a measure of the dispersion of the scores. Scores far from the average result in a larger value than scores close 
to the average.



Technical Support

Please contact A2ZWare Technical Support if you are having any technical problems with the software. Please do 
not contact A2ZWare for information about your registration payments. A2ZWare does not process 
payments. Contact Kagi at admin@kagi.com for questions concerning your payment. 

When contacting Technical support, please include the following information:

1. A complete description of the problem
2. Your registration name if registered (Registered to Registration Name    at the top of the screen)
3. The version number of the software. (Select About Gradebook from the Help menu)
4. Your Windows version (Windows 3.1, Windows 95, etc.)
5. Your processor type if you know it (486, Pentium, etc.)
6. Any other information which might be important

A2ZWare Technical Support can be contacted in these ways
1. Send e-mail to a2zware@aol.com. 
2. Visit our web site at http://members.aol.com/a2zware/index.htm



Viewing Student Information

The averages for a student can be viewed graphically by selecting View Student Information from the Students menu.
A form will be shown with the students first name, last name, student ID, notes, memo, and a graph of the students 
grades.

The students first name, last name, student ID, notes, and memo can be changed on this form.

The information for a different student can be viewed by selecting the Students menu on this form.

The graph is controlled using the Plot menu. The Select Classes option allows you to select up to six classes to plot. 
The Plot Scores option plots the average of each score as a vertical line. The Plot Cumulative Averages lets you view
how the students average has changed with each assignment.
The Grid On option prints a grid on the plot. 

Clicking and dragging the cursor over the plot displays the average and date for the cursor position on the plot.

To return to the grade form, select the Exit menu.

Additional Help Topics:
Reports



Weights

Weights provide a way to specify how much each assignment score is worth, relative to the other assignments. The 
Use Weights option can be turned on and off from the Class Information Frame.

For example, if the assignments for a class are three tests and an exam, and the exam is to be worth twice as much 
as the tests, each test could be assigned a weight of 1 and the exam could be assigned a weight of 2.

Another way of looking at this would be to say that each test is worth 20% of the grade and the exam is worth 40%. 
Each test could be assigned a weight of 20 and the exam could be assigned a weight of 40. 

The same averages would result from either of these methods. 

Selecting or deselecting Use Weights in the Class Information Frame has a significant effect on average calculations,
even if all weights are set to 1. Consider this example:

Max Points Score Average
Quiz 1 20 14 70%
Quiz 2 20 13 65%
Test 1 100 95 95%
Test 2 100 89 89%

If Use Weights is not selected, the average is calculated by dividing the sum of the scores (211) by the sum of the 
maximum possible points (240). The result is an average of 87.9%.

If Use Weights is selected and all of the weights are set to one, the average is calculated by dividing the sum of the 
averages times the weights (319) by the sum of the weights (4). The result is an average of 79.8%.

To calculate the weights for a group of assignments, select Edit Weights from the Assignments menu. Select the 
classes you want to group together and then enter the total weight for the group. Then select Apply.    The weight 
editor will calculate the weight for each assignment. Continue doing this until all of the assignments have weights 
assigned.    Then select OK.

Additional Help Topics:
Calculating Averages
Class Information Frame



Working With the Grade Form

After you create or open a gradebook, the grade form is displayed. When no class is selected the grade form is blank.
Add a new class or select a class, and a grid appears with the students names, averages, and grades you assign, 
assignments, and scores for each assignment. Student grades and assignment scores can be changed by clicking on
the appropriate cell in the grid. The menu at the top of the form allows you to access the data for classes, students, 
and assignments. There are also two preformatted reports available.

Additional Help Topics:
Changing the password
Closing the gradebook
Class information
Assignment information
Reports
Adding a class
Selecting a class
Changing the class roster
Deleting a class
Deleting a student
Viewing student information
Adding an assignment
Deleting an assignment




